Sort by "true" distance?

General Moho topics.

Moderators: Fahim, Distinct Sun, Víctor Paredes, erey, Belgarath, slowtiger

Post Reply
User avatar
chucky
Posts: 3924
Joined: Sun Jan 28, 2007 4:24 am
Location: Van Diemen's Land
Contact:

Sort by "true" distance?

Post by chucky » Wed Nov 03, 2010 5:11 am

Another workaround here I guess,
I can see how to get around this (clumsily) but once again it means making copies of particle systems and being very careful about keyframes.
That only fixes the problem of the entire layer switching, even then, individual particles are always laid down in order of appearance rather than actual z depth.

Example: Incorrect layer depth

I really wish there was a toggle to include the layers inside the particle group in the "sort by true distance" properties.

That way particle layers would stay in correct intended order and particle systems could actually go around objects without strangely switching the depth of the whole particle group instead of what we would actually expect to happen.

All this is rather ironic in light of the new '3d' options made available.
Sequential offender.
my latest animations
Genete
Posts: 3483
Joined: Tue Oct 17, 2006 3:27 pm
Location: España / Spain

Post by Genete » Wed Nov 03, 2010 7:43 am

Hey chucky,
from your video of wrong particles depth it is clear that you've made this setup:

Group folder
-Pyramid
-Particle layer
--Particle 1
--Particle 2
-- ...

then you've applied true z depth sort for the group folder and possibly for the particle "folder".

With the current particle concept in AS it is impossible to make it the effect you want (turn around the pyramid) because the particles are rendered as a whole and after that composited with the Pyramid using the Group folder zdepth calculations.

To be make possible your request, the particles folder itself should have the option to disable some layers from the particle effect and then you can split the particle in parts depending on where the particles are in z relative to others. That leads to other problem. Current particle system in AS picks up the particles to be rendered in a random selection to make them less predictable. So to allow internal sort of the particles items by its z depth another option must be enabled in the particles system. Possibly it would produce a less random particles system.

Only inserting the pyramid inside the particles layer you can produce that desired z depth sort.

I don't find other way to fix this unless the core particles system were changed.

And it is not related to the new 3D capabilities.

I wonder, does Particle Illusion, After Effects, Blender, Maya or whatever other application with particles allow to do what you want?

-G
User avatar
chucky
Posts: 3924
Joined: Sun Jan 28, 2007 4:24 am
Location: Van Diemen's Land
Contact:

Post by chucky » Wed Nov 03, 2010 7:49 am

Thanks Genete ,
I understand that this problem is not new, but it IS none the less ironic that there is such flaws in the layer depths when, these additions of 3D have been implemented.

I also understand exactly why this is happening, that does not means I am happy about it.

BTW I like your dog, his front end stomps, while his back end cheerfully jogs, amusing.

All those other programs of course can do that and more, maybe its time to move from anime studio.
Sequential offender.
my latest animations
Post Reply