Try this if Moho is not running smoothly

Have you come up with a good Moho trick? Need help solving an animation problem? Come on in.

Moderators: Fahim, Distinct Sun, Víctor Paredes, erey, Belgarath, slowtiger

Post Reply
Daxel
Posts: 106
Joined: Wed Mar 27, 2019 8:34 pm

Try this if Moho is not running smoothly

Post by Daxel » Sun Sep 13, 2020 3:16 pm

One or more conflictive references in your proyect may be causing Moho to run slow (slow response time and jittery reproduction of the timeline) even if your PC is powefull and Moho's CPU and GPU usage is not elevated.

To see if this is slowing down your program, make a simple animation and see how it runs. Then, turn off the visibility (the eye icon) of all your reference layers to see if the animation runs better.
If you notice that now the animation is smoother, then you have some conflictive reference layer/s. Try enabling the visibility of your references one by one to find the conflictive one. When you find it, just remake the reference and problem solved.

References get corrupted easily if you are modifying the original, so you may encounter the same problem again in the future, but it's easy to fix.

Other kind of problems:
The first time I was having problems with Moho being too slow, I looked for solutions here and found many useful tips to make Moho use less CPU and less GPU. But that didn't help me because that wasn't my problem. My program was slow even with a low CPU and GPU usage. If your PC is not powerful enough, you may benefit from those tips aswell, so here you have the best ones: http://lostmarble.com/forum/viewtopic.php?p=189290

Hope it helped!
User avatar
Greenlaw
Posts: 4719
Joined: Mon Jun 19, 2006 5:45 pm
Location: Los Angeles
Contact:

Re: Try this if Moho is not running smoothly

Post by Greenlaw » Mon Sep 14, 2020 4:55 pm

For me, one cause of a major slow down happens when an unintended pre-zero keyframe is created. Because this keyframe(s) can appear a thousand or more keyframes before frame zero, the extra evaluation Moho has to calculate puts a major drag on performance. (Mostly affecting interactivity.)

To correct this error, you need to delete these unintended keyframes. Since Moho won't let you see negative frames, the easiest way to do this is to use Synthsin75's script available from here:

Find and delete negative keyframes


Normally, Moho performs quite well even with very complex rigs and multiple characters, so when it suddenly slows down, this is the first thing I suspect. A quick way test this is to open an earlier version of your project and check the performance there. (This assumes you make frequent incremental saves, which you really should when working in any program.)

I'm still not sure what causes the unwanted keyframe(s) to be created, but fortunately, this error occurs very rarely with Moho 12.5.
Last edited by Greenlaw on Mon Sep 14, 2020 8:09 pm, edited 4 times in total.
D.R. Greenlaw
Artist/Partner - Little Green Dog | Little Green Dog Channel on Vimeo | Greenlaw's Demo Reel 2019 Edtion
Lead Digital Animator, Dreamworks Animation

Image
Daxel
Posts: 106
Joined: Wed Mar 27, 2019 8:34 pm

Re: Try this if Moho is not running smoothly

Post by Daxel » Mon Sep 14, 2020 7:51 pm

Greenlaw wrote:
Mon Sep 14, 2020 4:55 pm

I'm still not sure what causes the unwanted keyframe(s) to be created but fortunately, this error occurs very rarely with Moho 12.5.
Yes, actually it never happened to me. Only the reference problem, so far. The link I pasted contains that script solution and other useful ones in a comment you made, so I pasted it in the post in case there was someone here who needed it. Anyone could make the best Moho manual only pasting your comments in it. :wink:
Post Reply