Layer disappears with Smart bone dial

General Moho topics.

Moderators: Fahim, Distinct Sun, Víctor Paredes, erey, Belgarath, slowtiger

Post Reply
User avatar
Annapriori
Posts: 7
Joined: Mon Dec 09, 2019 12:10 pm

Layer disappears with Smart bone dial

Post by Annapriori » Mon Jun 08, 2020 3:49 pm

Hello people,

I have a problem using Moho 12. When I am creating a new smart bone and smart bone dial - the main vector layer disappears. It creates same actions twice - f.e. "B15" and "B152" automatically. Also I cannot delete the keyframes of the layer on keyframe o.
Does anybody know what can it be and how to fix it? I restarted the comp, program etc.
Last edited by Annapriori on Tue Jun 09, 2020 10:46 am, edited 1 time in total.
User avatar
alanthebox
Posts: 90
Joined: Sat Feb 03, 2018 5:31 pm
Location: california
Contact:

Re: Layer disappears with Smart bone dial

Post by alanthebox » Mon Jun 08, 2020 8:02 pm

It sounds like it's behaving as anticipated. The main timeline (and any keyframes you've created for the main bone group) should disappear in favor of the timeline you've created for this new action. The double actions you're seeing are probably due to the "separate actions for positive and negative angles" being turned on. Lastly, i don't think you can delete the keyframe that appears at frame 0. I believe that your smart bone dial actions should start at frame 1 and extend to the duration you've defined. So, the frame 0 keyframe shouldn't really dictate what's happening within the smart bone action.
User avatar
Annapriori
Posts: 7
Joined: Mon Dec 09, 2019 12:10 pm

Re: Layer disappears with Smart bone dial

Post by Annapriori » Tue Jun 09, 2020 8:32 am

Thanks a lot. I tried different things but the vector layer is still disappearing. The rest works well (dbl actions etc. - thank you!). The animation character was imported from another anime file, maybe it caused the problem. I will try to build a new skeleton. :roll: :P
User avatar
alanthebox
Posts: 90
Joined: Sat Feb 03, 2018 5:31 pm
Location: california
Contact:

Re: Layer disappears with Smart bone dial

Post by alanthebox » Tue Jun 09, 2020 5:14 pm

Oh, I see. Sorry, I misunderstood what was happening. Hopefully it wasn't too complex of a rig!
Post Reply