Timelag while animating

General Moho topics.

Moderators: Fahim, Distinct Sun, Víctor Paredes, erey, Belgarath, slowtiger

Post Reply
User avatar
Designspaceman
Posts: 21
Joined: Sun Oct 04, 2009 1:47 pm

Timelag while animating

Post by Designspaceman » Mon Jun 24, 2019 8:19 am

Hi Animators,
I have a question concerning Moho 12. I build a character in eight different views. Every view contains some actions, switches and patches. Nothing unusual so far. In the scene only one view is visible at a time.
Now I'm starting to animate and get a time lag between grabbing a bone and the response of Moho. I'ts nearly 2 seconds per grab. When I delete some views from the file it's getting faster. When I have only one view in the scene i'ts fast as usual.
I switched of everything from the displayquality, but no change in behaviour.
Well eight characters (seven even not visible) ist not that much. Has anybody experienced this too? Do anybody know a trick to avoid this?
Greetings
The Spaceman
amanandink
Posts: 231
Joined: Wed Feb 13, 2008 10:28 pm
Location: Kilkenny, Ireland
Contact:

Re: Timelag while animating

Post by amanandink » Mon Jun 24, 2019 8:27 am

hey Designspaceman
we have experienced that, but out rigs can be very complex, so i guess its not only the number of models but how complex they are and if you are running any layer scripts inside them. We usually store the views off in a separate file and only bring in the views you need into a scene, as you need them. that way the file is as small as possible for as long as possible.
User avatar
chucky
Posts: 3939
Joined: Sun Jan 28, 2007 4:24 am
Location: Van Diemen's Land
Contact:

Re: Timelag while animating

Post by chucky » Mon Jun 24, 2019 9:48 am

The biggest cause of lag in Moho currently is vector brushes, always turn them off in display... until the render revolution comes
Sequential offender.
my latest animations
Post Reply