"It appears that a file was not properly saved last time."

General Moho topics.

Moderators: Fahim, Distinct Sun, Víctor Paredes, erey, Belgarath, slowtiger

Post Reply
Debo
Posts: 63
Joined: Tue Feb 26, 2008 11:26 pm

"It appears that a file was not properly saved last time."

Post by Debo » Mon Nov 26, 2012 3:55 am

This message nearly always appears when I open an .anme file. The files I open were made using AS 5.6. ""It appears that a file was not properly saved last time. Would you like to recover it?"

I'm using a trial version of AS 9.1 on a Mac OS 10.8.2. It's getting really annoying now, as the .anme projects I open are all automatically re-named "Recovered File". And it's always the previous project that opens, not the current one. Whereas I always make sure I save them.

What's going on?
User avatar
slowtiger
Posts: 5403
Joined: Thu Feb 16, 2006 6:53 pm
Location: Berlin, Germany
Contact:

Re: "It appears that a file was not properly saved last time

Post by slowtiger » Mon Nov 26, 2012 10:11 am

Can't test here, but does the same happen with files you saved in v9.1 format?
Debo
Posts: 63
Joined: Tue Feb 26, 2008 11:26 pm

Re: "It appears that a file was not properly saved last time

Post by Debo » Mon Nov 26, 2012 2:48 pm

Yes, I always receive that message.
User avatar
Lukas
Posts: 789
Joined: Fri Apr 09, 2010 9:00 am
Location: Netherlands
Contact:

Re: "It appears that a file was not properly saved last time

Post by Lukas » Mon Nov 26, 2012 3:15 pm

On 9.0 I didn't have it at all though, even after a crash, so I couldn't recover.

But now, I also ALWAYS have this message when I start ASP 9.1

(Still much much better than losing work after a crash though!)
User avatar
AmigaMan
Posts: 1017
Joined: Thu Sep 14, 2006 3:40 pm
Location: UK
Contact:

Re: "It appears that a file was not properly saved last time

Post by AmigaMan » Mon Nov 26, 2012 9:27 pm

AS crashes on closing every time for me but, so far, it's not corrupted any files.
wagmun
Posts: 57
Joined: Mon Apr 26, 2010 10:43 pm

Re: "It appears that a file was not properly saved last time

Post by wagmun » Thu Feb 28, 2013 2:16 pm

Same happening to me.
Have installed v9.2 a couple of days ago and everytime I open it,
I opened a file "Moving Body.anme" and made some tests, not saving it in the end and closing ASP.
Nest time I opened ASP it said "it appears that a file was not properly saved last time. Would you like to recever it?".
Every time I had this situation I tried different replies to "would you like to recover it?":
- No
Did my work, closed, etc, and next time I opened ASP, got the same error message,
- Yes, and then saving the recovered file as "recovered file", keeping the name
Did my work, closed, etc, and next time I opened ASP, got the same error message,
- Yes, and then saving it with another name
Did my work, closed, etc, and next time I opened ASP, got the same error message,
- Yes, and then saving it with the name of the original name file had.
Did my work, closed, etc, and next time I opened ASP, got the same error message,

I've create a new blank file and saved it. Closed ASP. And when opening ASP again, same message. Interesting to note that error message referred always to "Body moving.anme", even after I worked on another file, which means I'll have this message even after this project is finished and erased from my Macbook (running Mountain Lion).

Any ideas?
wagmun
Posts: 57
Joined: Mon Apr 26, 2010 10:43 pm

Re: "It appears that a file was not properly saved last time

Post by wagmun » Thu Feb 28, 2013 8:21 pm

Contacted support and they gave me the folowing solution, which worked for the time being:
Go to Mac HD/Users/(username)/Library/Preferences/Smith Micro/Anime Studio Pro/9/ directory. There should be an "Autosave.anme" file there. Delete it.

Hope it helps for those who might face this problem in the future.
arfa
Posts: 244
Joined: Tue Dec 23, 2008 8:15 pm
Location: New Zealand

Re: "It appears that a file was not properly saved last time

Post by arfa » Mon Mar 11, 2013 12:46 am

Yes, a bit irritating.
ver9.0 - same msg.
Only seems to happen when there is another instance already open.

PC - roughly the same path - users/ ?? /AppData/Roaming/SM/AS/9/Autosave.anme

I renamed - restarted - same msg.
I deleted - same msg
For both of these approaches a new Autosave.anme file was created

I tried switching off 'autosave for crash recovery' in preferences - nope.

Just click no and it loads the new file.

I manually changed to: "AutoSave" "FALSE" in AS.user.settings
Seemed to fix it - but doesn't allow autosave [altnhough I switch it off anyhow]
User avatar
drumlug13
Posts: 489
Joined: Sun May 22, 2011 9:16 pm
Location: Beautiful St. Louis, MO

Re: "It appears that a file was not properly saved last time

Post by drumlug13 » Mon Mar 11, 2013 2:16 pm

This is a little bit different situation but...

In past versions I remember being able to have 2 projects opened at the same time. Now if you have one opened it has to be closed before opening another. Otherwise the "It appears that a file was not properly saved last time" alert will show.
arfa
Posts: 244
Joined: Tue Dec 23, 2008 8:15 pm
Location: New Zealand

Re: "It appears that a file was not properly saved last time

Post by arfa » Mon Mar 11, 2013 10:03 pm

@ drumlug13
any solution or resolution?
User avatar
drumlug13
Posts: 489
Joined: Sun May 22, 2011 9:16 pm
Location: Beautiful St. Louis, MO

Re: "It appears that a file was not properly saved last time

Post by drumlug13 » Mon Mar 11, 2013 10:26 pm

Watch this video. It's a solution for Bad File Headers, but if it's worth a try if the file won't open at all.

Keep in mind that I'm completely clueless about this stuff.
http://www.youtube.com/watch?v=iWFfJrpF-Wg
deadcatdreaming
Posts: 1
Joined: Thu Aug 11, 2011 9:48 am

Re: "It appears that a file was not properly saved last time

Post by deadcatdreaming » Fri Jul 26, 2013 11:11 am

Wagmum's instructions re deleting the "Autosave.anme" file worked for me, though it did take me a while to find the correct library folder. For others running ASP on mountain lion, the easiest way to find the folder is to option-click the Go menu in Finder and choose Library. You can then follow the rest of Wagmum's instructions -
/Preferences/Smith Micro/Anime Studio Pro/9/ directory. There should be an "Autosave.anme" file there. Delete it. :D
'but satisfaction brought it back'
Post Reply