Audio functions on Linux

Answers to the most commonly asked Moho questions.

Moderators: Fahim, Distinct Sun, erey

Audio functions on Linux

Postby Lost Marble » Mon Dec 05, 2005 11:09 pm

All of Moho's and Papagayo's audio functions are now available in the Linux versions of these programs. However, you may need to do some additional system configuration to get audio working properly. If you use the Animation->Select Soundtrack menu command in Moho and you see an audio waveform in the timeline but you don't hear anything when you play back the animation, try the following steps:

1) First, make sure that audio is working on your computer. Can other programs play back audio files? (It can sometimes be tricky to get audio working on Linux.)

2) Next, check to see if an audio device is present. Enter the following command in a terminal window:

> ls /dev/dsp*

You should see one or more devices listed.

3) Next, check to see if another process has exclusive access to the audio device. Enter the following command:

> fuser /dev/dsp

If the audio device is free, then nothing should print out. If another process is using the audio device, a number will come back - the number of that process. Both KDE and Gnome have their own little sound server deamons that start when you log on - the process is likely one of those. Try turning it off. Exactly how to do this depends on your system, but here's an example with Ubuntu: Select the System->Preferences->Sound menu command, and in the control panel that comes up, turn off "Enable sound server startup". Try logging out and back in and see if Moho plays audio now.

4) If that didn't fix it, try the following command again:

> fuser /dev/dsp

If a process is still listed as using the audio device, you can find out the name of the process by using pgrep. Try the following command (with your actual username):

> pgrep -l -u username

Look in the list for a number matching the process you found in step 4. The name of the process may give you a clue as to what program it is. Try to disable that program at startup. If you can't figure out which process is accessing the audio device, you can try to kill it anyway, using the following command:

> kill -9 `fuser /dev/dsp`

Try starting Moho up again and playing a sound. If that solved the problem, you can add the command above to the 'moho' startup script.
User avatar
Lost Marble
Site Admin
 
Posts: 2148
Joined: Tue Aug 03, 2004 6:02 pm
Location: Scotts Valley, California, USA

Return to FAQ

Who is online

Users browsing this forum: No registered users and 1 guest