Layer order doing odd things

Discuss Moho bugs (or suspected bugs) with other users. To report bugs to Smith Micro, please visit support.smithmicro.com

Moderators: Fahim, Distinct Sun, Víctor Paredes, erey, Belgarath, slowtiger

Post Reply
User avatar
foundmarble
Posts: 91
Joined: Fri Nov 05, 2004 12:33 am

Layer order doing odd things

Post by foundmarble » Fri Nov 05, 2004 12:54 am

Here is my example:
The closest (or first) layer is at 0,0,0 (xyz). My character resides on this layer
The next layer in line is at 0,0,0 (x,y,z). My background resides on this layer.

I have a check in the box for SORT BY DEPTH in the main preferences menu.

For some reason the background appears before my character.
The only way to fix this is if I take my background layer to -2 or -3 on the z plane.

It will work for the most part, then.....

I move my character and again the background appears before my character in some areas of my project.

From this point, I move the background yet again on the z plane (to about -5)
It fixes this.

I know my layers are spaced apart. I can prove this using the 3d camera and actually seeing the space between layers.

I can work around it, however, I gets really difficult when you have a lot of layers.
Is this a bug?


HELP!
User avatar
Lost Marble
Site Admin
Posts: 2193
Joined: Tue Aug 03, 2004 6:02 pm
Location: Scotts Valley, California, USA
Contact:

Post by Lost Marble » Fri Nov 05, 2004 4:35 am

For the first part, when two layers are both at 0,0,0, they're at the same position, and Moho has to just arbitrarily pick one to be in front of the other. If you're using depth sorting, your layers must be at different depths.

Which brings us to part 2...

A sample file would really help figure this out. Are you saying that sometimes the background is behind the character, and sometimes in front - as the character or camera moves or something? Or are there some parts of the background that are in front of the character? I'm not sure what to tell you without seeing the file.

And finally, are you sure you really want "Sort by depth" turned on? You should only use that if you want layers to change order over time, as one moves in front of and behind another. If all you want is to have a background layer behind a character, leave "Sort by depth" turned off, and just put the background layer lower in the ordering.
User avatar
foundmarble
Posts: 91
Joined: Fri Nov 05, 2004 12:33 am

Post by foundmarble » Fri Nov 05, 2004 5:33 am

I turned off the sort by depth setting. I think that was my problem. I though you needed to have that on when you changed the z axis.
I am still figuring out some of the options. I am new :oops:

P.S.
Love the program.
Ever think about changing the site "look"? Just seems a little plain for a great program.

my 2 cents.
Post Reply