Moho 12.2 PROBLEM on Mac 10.12.3

Discuss Moho bugs (or suspected bugs) with other users. To report bugs to Smith Micro, please visit support.smithmicro.com

Moderators: Fahim, Distinct Sun, Víctor Paredes, erey, Belgarath, slowtiger

Moho 12.2 PROBLEM on Mac 10.12.3

Postby zakimon23 » Mon Feb 27, 2017 9:40 am

Hi, I use macOS 10.12.3 and I can't run MOHO 12 on my mac. I upgrade from Anime Studio 11, and I download dmg file, but when I install the app, I stuck. I can't run it properly. Just this screen pop up, and I don't know how to fix it? I update my mac to the latest version, and I do everything I can but still can't run the app :( Please for help.
Image
Thanks,
Zafir
zakimon23
 
Posts: 2
Joined: Sun Feb 26, 2017 11:44 pm

Re: Moho 12.2 PROBLEM on Mac 10.12.3

Postby zakimon23 » Tue Feb 28, 2017 9:30 pm

Anyone?
zakimon23
 
Posts: 2
Joined: Sun Feb 26, 2017 11:44 pm

Re: Moho 12.2 PROBLEM on Mac 10.12.3

Postby dolarfred » Sun Mar 05, 2017 6:07 pm

i've got about the same problem.

i've contacted the smith micro support, without result a this day.
I've done a test,
Can you try this also :

Close the moho app

From 12.0 version (which runs for me) :
Click Right on Moho.app V12.0 and select 'show packet content'
Open content folder,
Open Frameworks folder
Copy liboiio.dylib
Close windows

Click Right on Moho.app V12.2 and select 'show packet content'
Open content folder,
Open Frameworks folder
Duplicate liboiio.dylib (to put it back after test)
Paste the liboiio.dylib (which come from the V12.0) in the Frameworks folder
Close window

Try to run the Moho.app V12.2

For me, the program runs but i can't be sure that everything is allright....!!


After this test you can return to the initial version of Moho V12.2 , do this :
close the app
Open Moho V12.2
Click Right on Moho.app V12.2 and 'show packet content'
Open content folder,
Open Frameworks folder
Remove the liboiio.dylib (from the V12.0 you've pasted) , (trash it)
Rename the liboiio.dylib (you've duplicated) copy back to liboiio.dylib
the initial configuration is retablished

Close the windows

Tell me if the result is the same as me
after this test, it coud be an interessant indication to solve the problem...
(excuse my English, i'm french)
dolarfred
 
Posts: 1
Joined: Sun Mar 05, 2017 11:02 am

Re: Moho 12.2 PROBLEM on Mac 10.12.3

Postby johnfromncl » Mon Apr 10, 2017 9:02 am

I also have/had the same problem. This is included here in case the things that Tech suggested - that did not work for me - actually do work for others.

For me, this has been experienced with both Mac 10.12.3 and with 10.12.4.

I am new to Moho/Anime, so was installing from scratch, and have never had the program launch successfully. On my own initiative, I deleted all the Moho bits I could find for completely clean reinstalls, but no luck with that approach (and no confidence at the time that I deleted everything either). I don't have a previous version I can try copying bits from in an attempt to fix this myself - in line with the suggestions in this thread from another forum user.

Moho Tech Support did query my permissions which I have altered, but this did not sort the problem. I checked and altered the permissions for the following folders using Get Info to become Read and Write for all options visible

/Users/Shared/
/Users/Shared/Library/
/Users/Shared/Library/Application Support/
/Users/Shared/Library/Application Support/Smith Micro/
/Users/Shared/Library/Application Support/Smith Micro/Moho/
/Users/Shared/Library/Application Support/Smith Micro/Moho/12/

They also got me to move the /12/ folder to the desktop, but no resolution from that either.

Also tried creating a new user account and installing on that, but no resolution.

Tech's last diagnosis - in response to all the above - was:

"The crash reports seem to indicate a permission issue, but nothing specific.
Since the normal trouble shooting (new User Account) has no impact, it may be the system permissions or some process running is leading to the failure.
Have you tried a Safe Boot and if so, is the Crash Log the same?
If so, that would rule out any third process and limit the issue to system permissions or corruption of the installation.
The issue with the newer Frame work indicates either your system is not fully up to date, or the installation is corrupted.
If you left an older version installed that also would cause issues. The Updated installer should uninstall the older version. Two versions of the Moho 12 can not exist in the same environment."

This left me a little doubtful of Moho 12 Pro ever working successfully - and on an ongoing basis - on my mac.

My solution - not ideal, but at least available to me - was to give up on using my mac and to use my partners mac instead. Everything worked smoothly on that, and the program has launched, and I've entered my activation code.

Now looking forward to learning and using the software. Have done a bit of playing already, and everything seems to be working. Hooray!

Anyone interested in learning from Moho's video tutorials might like to see the following which suggests a good order for viewing them: http://www.animationandvideo.com/2016/0 ... o-pro.html
johnfromncl
 
Posts: 1
Joined: Mon Apr 10, 2017 12:17 am


Return to Bug Discussions

Who is online

Users browsing this forum: No registered users and 1 guest

cron