shape effects is the worst thing to ever happen to me.

Wondering how to accomplish a certain animation task? Ask here.

Moderators: Fahim, Distinct Sun, Víctor Paredes, erey, Belgarath, slowtiger

shape effects is the worst thing to ever happen to me.

Postby sargumphigaus » Sun Apr 24, 2016 6:36 am

There appears to be a cancer in this program called "Shape Effect" it just pops up on the timeline automatically, I don't put it there, in fact, I do nothing to bring it into my animation...and what it does is it automatically adjusts my animation in a gradual process. Making things blurry. I set my animation to soft edge level 2 both on fill and stroke, and "Shape Effect" decides, yeah screw you! I'm going to bring it up to 50 by frame 200, and there's nothing you can do about it......HOW DO I SHUT SHAPE EFFECT OFF!? seriously...I just lost 8 hours to this seemingly pointless process...how do I stop it? Whoever decided to incorporate it, might as well have installed a feature that makes a fist fly out of your monitor and punch you in the face. Because that's what this feels like.
User avatar
sargumphigaus
 
Posts: 398
Joined: Tue Mar 06, 2012 9:38 pm

Re: shape effects is the worst thing to ever happen to me.

Postby Greenlaw » Sun Apr 24, 2016 7:12 am

It sounds you've accidentally keyframed an Effect in a Style to change over time. That sometimes happens to me if I'm not paying attention to what frame I'm on when I'm adjusting my styles. What's annoying is that you won't see the keyframes on the timeline if it's in a custom Style. A while back somebody (probably Synthsin75) showed me how to get around this issue.

First, go to the custom style you created and click the Copy button (I mean the one at the bottom of the Style Panel.) This places the style properties, including the 'unreachable' Effect keyframes, on the clipboard. Now create a new shape (a circle or rectangle primitive is fine) and select the shape. Make sure the custom Style isn't applied to the shape and click the Paste button. Now you should see the keyframes for the Effect on the timeline. (In your case, I'm guessing it's the Edge Blur effect.) Delete the keyframes and enter the constant value you want at frame zero. Use the Copy button to copy this edited Style and paste it back into your custom Style. Now your shapes that use this Style should not be affected by the unwanted keyframes.

Hope this helps.
Last edited by Greenlaw on Sun Apr 24, 2016 7:31 am, edited 7 times in total.
User avatar
Greenlaw
 
Posts: 3409
Joined: Mon Jun 19, 2006 5:45 pm
Location: Los Angeles

Re: shape effects is the worst thing to ever happen to me.

Postby Greenlaw » Sun Apr 24, 2016 7:22 am

Yeah, it was Synthsin75 who helped me. Here's the thread:

Editing Keyframes For Styles

If my instructions above aren't very clear, try following his instructions.
User avatar
Greenlaw
 
Posts: 3409
Joined: Mon Jun 19, 2006 5:45 pm
Location: Los Angeles

Re: shape effects is the worst thing to ever happen to me.

Postby sargumphigaus » Sun Apr 24, 2016 5:22 pm

I don't use style feature. It's nothing but trouble to me. Every time I use it, it destroy everything I create. I've tried hundreds of times to establish it into doing something "basic" followed every tutorial, but the mere fact that styles are limited to one color, just makes it way too redundant, especially since you can't carry them over to other files. waste of time. So it isn't the style that is ripping my animation apart. It's something entirely different.
User avatar
sargumphigaus
 
Posts: 398
Joined: Tue Mar 06, 2012 9:38 pm

Re: shape effects is the worst thing to ever happen to me.

Postby Greenlaw » Sun Apr 24, 2016 5:57 pm

I don't think I can change your mind about it but I use Styles at work and at home all the time. If your Styles are carefully designed and planned, it can save a lot of time and headaches when changing the looks for characters, props, etc. On a commercial production, being able to change quickly entire palettes on demand can be critical on a tight schedule.

I'm not sure what you mean by "Limited to one color". AFAIK, a custom Style has the same properties as a regular Style but with the advantage of referencing. The only disadvantage I'm aware of is that bit I mentioned earlier about the Effects keyframes not appearing on the Timeline. But once you're aware of what causes the problem, it can be corrected and avoided as described.

As for your statement that "you can't carry them (Styles) over to other files," that's not correct. You certainly can:

Image

I started using this method a few months ago but even before that, transferring Styles was simply a matter of importing layers that contained the Styles you needed and then applying them to the new scene. I used to set up colored 'chips' in layers as my importable Style guides but then I got lazy and began to directly import props and characters that had the styles I wanted. After importing, the Styles are added to the Styles list. When your done applying the Styles you want, just delete the imported layer(s).

However, the new Library method allows you to be better organized about it and I recommend it.
Last edited by Greenlaw on Tue Apr 26, 2016 4:43 pm, edited 7 times in total.
User avatar
Greenlaw
 
Posts: 3409
Joined: Mon Jun 19, 2006 5:45 pm
Location: Los Angeles

Re: shape effects is the worst thing to ever happen to me.

Postby sargumphigaus » Sun Apr 24, 2016 6:06 pm

that's all well and good, but I just spent the last 3 hours recreating something that the Shapeeffects cancer tool utterly destroyed on me. And now every time I add something new, the shape effects jumps back on board and automatically keyframes a progression towards a different setting, and now we know it isn't "Style" oriented...

Image




seriously...I don't have much time these days, and to be put in a situation where I have to spend hours FIGHTING the program instead of using it...I'm ripping my hair out right now....
User avatar
sargumphigaus
 
Posts: 398
Joined: Tue Mar 06, 2012 9:38 pm

Re: shape effects is the worst thing to ever happen to me.

Postby Greenlaw » Sun Apr 24, 2016 6:26 pm

I still think you have an accidental Effect or a accidental keyframe in an intentional Effect applied in your current Style. Since you're not using custom Styles, this should be easier to fix since the keyframes should appear on your timeline (as in the image you posted). I don't know how you've set up your scenes, so I can only make a few guesses but some of these suggestions may help.

1. Select the offending Shape with the Select Shape tool and look at the Style palette. Are there any Effects applied? Check all three Effect drop downs and remove any you might find. If this is what's happening, you'll have to repeat this for every shape that's blurring. (This is where using a custom Style is helpful since you'll in theory only have to do this once for the Style and the change would automatically update all shapes using that Style. But anyway...)

2. Or, select the shape and look at the timeline. If you see an icon that, for example, looks like a gradient (like the one in your screen cap,) that's probably the Effect that's been keyframed to get blurry over time. Delete keyframes if you want to keep the Effect constant and you're only objecting to the animation of the Effect. If you don't want the blurry effect at all, remove the Effect from the currently applied Style.

3. Of course, as an alternative to correcting all of these one by one, you can use the Copy/Paste buttons or the Eye Dropper/Bucket tools to apply the corrected non-blurring Styles. (I'm talking about regular Styles you use by default, not the custom ones.)

4. Now, if you had been using a custom Style does exist for the shape, just remove it from Style 1 and/or Style 2. Or, you can remove the Effect from the custom Style itself as mentioned previously. I'm just stating this one for other users since I know you're not using this feature.

5. It's possible that this isn't caused by a Style at all and it might actually be a keyframed Layer Effect setting. However, I don't think that's the case here based on your description but if it is, you should check your layer settings (including Groups) and see if an Effect is enabled or check for keyframes on the Timeline to remove the animation of the Effect.

6. I had a number 6 but I forgot what that was...brb. :)
Last edited by Greenlaw on Tue Apr 26, 2016 4:45 pm, edited 12 times in total.
User avatar
Greenlaw
 
Posts: 3409
Joined: Mon Jun 19, 2006 5:45 pm
Location: Los Angeles

Re: shape effects is the worst thing to ever happen to me.

Postby Greenlaw » Sun Apr 24, 2016 6:36 pm

6. Oh, yeah. The reason those unwanted properties keep showing up (again, this is just a guess because I can't see what's in your scene,) could be that they were/are part of the Style you're currently using. Default settings in the Style palette tend to persist for each new shape you create until you change the defaults. It's possible that you have an unwanted property set in your default Style. The way to check this is to have no shapes selected and then look at the Style palette. If you see any Effects applied in any of the three slots that you don't want, remove them. Now, when you create a new shape, it should not have the Effect applied. Also, make sure a Style doesn't exist in Style 1 or Style 2. If you see one, that's probably where the Effect is coming from. Just remove it (with no shape selected) and this should become your new default Style.

Naturally, this only solves the issue for new shapes you create and not older shapes that already have the blurring effect applied. If this is what's happening, you'll need to fix those using one of the methods previously described. Since it seems to be just a few shapes, this shouldn't take long even if you do it manually. If it's actually many dozens or more, you'll probably want to use the eyedropper/bucket to paste the corrections in.

Just to be sure, can you post a screen cap of your current Style palette setting? Maybe one with the offending shape selected and other without an item selected. At the moment, I can't think of anything else that might cause this problem but seeing the palettes will help eliminate the idea of Styles causing the problem.

In any case, I think I can safely say that what you're seeing is not normal behavior for ASP with factory default setting. My guess is that a default has been changed somewhere to make that Effect and those key frames appear for each new shape (whether this is occurring in a Style or elsewhere in ASP.)

Anyway, that's my thought at the moment. Hope this helps.
Last edited by Greenlaw on Sun Apr 24, 2016 7:37 pm, edited 4 times in total.
User avatar
Greenlaw
 
Posts: 3409
Joined: Mon Jun 19, 2006 5:45 pm
Location: Los Angeles

Re: shape effects is the worst thing to ever happen to me.

Postby Greenlaw » Sun Apr 24, 2016 7:02 pm

Project Settings is another place where a 'blurring' effect can be applied but I don't think this is what's happening since that should be a global effect. Just mentioning this for other users who might need this info in the future.
User avatar
Greenlaw
 
Posts: 3409
Joined: Mon Jun 19, 2006 5:45 pm
Location: Los Angeles

Re: shape effects is the worst thing to ever happen to me.

Postby sargumphigaus » Sun Apr 24, 2016 8:57 pm

You're alright in my book. I appreciate it.
User avatar
sargumphigaus
 
Posts: 398
Joined: Tue Mar 06, 2012 9:38 pm

Re: shape effects is the worst thing to ever happen to me.

Postby synthsin75 » Sun Apr 24, 2016 8:59 pm

Is the problem solved? If so, what was the issue?
- Wes
Image
User avatar
synthsin75
 
Posts: 6287
Joined: Mon Jan 14, 2008 11:20 pm
Location: Oklahoma

Re: shape effects is the worst thing to ever happen to me.

Postby sargumphigaus » Tue Apr 26, 2016 4:32 am

synthsin75 wrote:Is the problem solved? If so, what was the issue?


If you're on the timeline, at lets say frame 25 and raise soft edge to let's say...5 on fill. Then it automatically assumes that the soft edge MUST be at 5 by the time it gets to frame 25, going so far as to morph the fill into a setting of 5 for soft edge even if or if not you even plop anything down. It's weird that it does this, but at least I know why its happening and can take steps to avoid it in the future. If you change the setting on soft edge, the program just auto writes the point on the timeline it took place at. I would love to find away to deactivate that, because its easy to get really into animating a shot, and forget about it. But hey, it is what it is.
User avatar
sargumphigaus
 
Posts: 398
Joined: Tue Mar 06, 2012 9:38 pm

Re: shape effects is the worst thing to ever happen to me.

Postby sargumphigaus » Tue Apr 26, 2016 4:38 am

so the best fix is to catch it when it happens. Delete the morph points on the timeline and then click on it with the eyedropper.
User avatar
sargumphigaus
 
Posts: 398
Joined: Tue Mar 06, 2012 9:38 pm

Re: shape effects is the worst thing to ever happen to me.

Postby synthsin75 » Tue Apr 26, 2016 5:55 am

Yeah, most animated elements will be keyframed on the timeline when making a change on a frame higher than zero. I'm afraid this is very basic AS operation. Always expect changes on frames other than zero to create keyframes. Might want to review the user manual and tutorials in the Help menu.


I've gotten to where when I read a very panicked or dramatic post with words like 'worst', 'cancer', and 'destroy everything' I assume it's user error.
- Wes
Image
User avatar
synthsin75
 
Posts: 6287
Joined: Mon Jan 14, 2008 11:20 pm
Location: Oklahoma

Re: shape effects is the worst thing to ever happen to me.

Postby sargumphigaus » Tue Apr 26, 2016 3:04 pm

admittedly i have a few screws loose upstairs and have been known to exhibit "passionate" moments.
User avatar
sargumphigaus
 
Posts: 398
Joined: Tue Mar 06, 2012 9:38 pm

Next

Return to How Do I...?

Who is online

Users browsing this forum: No registered users and 1 guest

cron