Invisible mask - can't get it to work

Wondering how to accomplish a certain animation task? Ask here.

Moderators: Fahim, Distinct Sun, Víctor Paredes, erey, Belgarath, slowtiger

FeistyFettuccine
Posts: 13
Joined: Thu Jul 11, 2019 1:26 pm

Invisible mask - can't get it to work

Post by FeistyFettuccine » Wed Aug 07, 2019 10:43 pm

Image

Can you tell me what I'm doing wrong?

Layer 5 is set to mask all;
Star, door opening, and wall set to not mask this;
Mask (large rectangle shape) set to mask but keep invisible

What I'm trying to accomplish is having the star go through the door opening. Is this not how invisible masks work?

This is of course just a practice layout, eventually the plan is to have my character walk through a door and go inside a building.

Thanks.
User avatar
synthsin75
Posts: 7156
Joined: Mon Jan 14, 2008 11:20 pm
Location: Oklahoma
Contact:

Re: Invisible mask - can't get it to work

Post by synthsin75 » Wed Aug 07, 2019 11:16 pm

If you want the star to disappear into the door, it will need to be set "mask this layer", the group set to "show all", and the mask set to "subtract" (and probably aligned with the far edge of the door).
FeistyFettuccine
Posts: 13
Joined: Thu Jul 11, 2019 1:26 pm

Re: Invisible mask - can't get it to work

Post by FeistyFettuccine » Thu Aug 08, 2019 12:06 am

synthsin75 wrote:
Wed Aug 07, 2019 11:16 pm
If you want the star to disappear into the door, it will need to be set "mask this layer", the group set to "show all", and the mask set to "subtract" (and probably aligned with the far edge of the door).
That didn't work. Just for reference, I'm following the tutorial manual of moho pro 12.

I can think of a workaround, which is slicing the entire wall/door image in two, put it on two different layers with the star layer in between. But I feel it would defeat the purpose of having the masking capability in the first place.
User avatar
synthsin75
Posts: 7156
Joined: Mon Jan 14, 2008 11:20 pm
Location: Oklahoma
Contact:

Re: Invisible mask - can't get it to work

Post by synthsin75 » Thu Aug 08, 2019 12:40 am

FeistyFettuccine wrote:
Thu Aug 08, 2019 12:06 am
synthsin75 wrote:
Wed Aug 07, 2019 11:16 pm
If you want the star to disappear into the door, it will need to be set "mask this layer", the group set to "show all", and the mask set to "subtract" (and probably aligned with the far edge of the door).
That didn't work. Just for reference, I'm following the tutorial manual of moho pro 12.

I can think of a workaround, which is slicing the entire wall/door image in two, put it on two different layers with the star layer in between. But I feel it would defeat the purpose of having the masking capability in the first place.
If you did everything I said, it would work. If you want to post a link to your file, I can show you.
hayasidist
Posts: 2145
Joined: Wed Feb 16, 2011 8:12 pm
Location: Kent, England

Re: Invisible mask - can't get it to work

Post by hayasidist » Thu Aug 08, 2019 10:25 am

just as Wes said works fine … note that he said Reveal all and subtract from mask -- the mask has to be on the part of the wall that is to be in front of the star

or (as ever in Moho there are many ways to skin the cat)

Hide All; add to mask / invisible -- and the mask has to be on the part of the wall that is to be behind the star.

just ask if you want to see a file with those two options at work
FeistyFettuccine
Posts: 13
Joined: Thu Jul 11, 2019 1:26 pm

Re: Invisible mask - can't get it to work

Post by FeistyFettuccine » Thu Aug 08, 2019 12:56 pm

hayasidist wrote:
Thu Aug 08, 2019 10:25 am
just as Wes said works fine … note that he said Reveal all and subtract from mask -- the mask has to be on the part of the wall that is to be in front of the star

or (as ever in Moho there are many ways to skin the cat)

Hide All; add to mask / invisible -- and the mask has to be on the part of the wall that is to be behind the star.

just ask if you want to see a file with those two options at work
Yes please. I did exactly what Wes told me to do, without changing anything else like layer order, it resulted in the star disappearing behind the entire wall. A file made by you would probably be more helpful than going back and forth with screenshots :D
User avatar
Greenlaw
Posts: 4467
Joined: Mon Jun 19, 2006 5:45 pm
Location: Los Angeles
Contact:

Re: Invisible mask - can't get it to work

Post by Greenlaw » Thu Aug 08, 2019 3:40 pm

Here's an example file set up as Wes described. It really should work.

StarMask.moho Download

Make sure the group settings is set to Reveal All as shown below.

Image

The mask layer (the rectangle) should be set to' Subtract from Mask (...Invisible)'.

The wall layer is set to 'Don't mask this layer'. (Since we're masking the Star, not the wall or doorway.)

You can also do it the other way as Paul described: Use Hide All and move the mask to reveal where the Star appears. (I know, when you're new to this, the terminology may seem counterintuitive.)

Hope this helps.

Alternatively, you can split the wall into two layers, an FG and BG layer, and place the star layer in between. You can use a mask to mask the FG wall, or just draw the wall that way.
Last edited by Greenlaw on Thu Aug 08, 2019 10:02 pm, edited 3 times in total.
D.R. Greenlaw
Artist/Partner - Little Green Dog | Little Green Dog Channel on Vimeo | Greenlaw's Demo Reel 2019 Edtion
Lead Digital Animator, Dreamworks Animation

Image
User avatar
Greenlaw
Posts: 4467
Joined: Mon Jun 19, 2006 5:45 pm
Location: Los Angeles
Contact:

Re: Invisible mask - can't get it to work

Post by Greenlaw » Thu Aug 08, 2019 3:53 pm

Some tips:

I usually place the mask at the very bottom of the group. This isn't necessary, it's just a convention I follow for consistency and better organization. The mask does need to go below whatever is being masked though.

Hide All is the most commonly used mode, and it's usually the easiest to work with. Basically, a Hide All mask is used for what you want to reveal in the render. (Yeah, I know, confusing.) :)

In the case presented above, however, using Reveal All and Subtract is technically the better way to go.
D.R. Greenlaw
Artist/Partner - Little Green Dog | Little Green Dog Channel on Vimeo | Greenlaw's Demo Reel 2019 Edtion
Lead Digital Animator, Dreamworks Animation

Image
hayasidist
Posts: 2145
Joined: Wed Feb 16, 2011 8:12 pm
Location: Kent, England

Re: Invisible mask - can't get it to work

Post by hayasidist » Thu Aug 08, 2019 8:10 pm

FeistyFettuccine wrote:
Thu Aug 08, 2019 12:56 pm
hayasidist wrote:
Thu Aug 08, 2019 10:25 am
… just ask if you want to see a file with those two options at work
Yes please. ...
here's the file http://www.mediafire.com/file/dv694oa6g ... .moho/file -- hope that helps (as should Dennis's)
FeistyFettuccine
Posts: 13
Joined: Thu Jul 11, 2019 1:26 pm

Re: Invisible mask - can't get it to work

Post by FeistyFettuccine » Mon Aug 12, 2019 1:59 pm

Greenlaw wrote:
Thu Aug 08, 2019 3:53 pm
Some tips:

I usually place the mask at the very bottom of the group. This isn't necessary, it's just a convention I follow for consistency and better organization. The mask does need to go below whatever is being masked though.

Hide All is the most commonly used mode, and it's usually the easiest to work with. Basically, a Hide All mask is used for what you want to reveal in the render. (Yeah, I know, confusing.) :)

In the case presented above, however, using Reveal All and Subtract is technically the better way to go.
Thanks! Yeah it's pretty confusing as it the opposite of most design software, which places the mask above the layer you like to mask (or moving the latter into the mask layer). Plus the moho tutorial manual also works with the hide all to reveal things :shock:

But a manner of adapting I guess. Thanks again.
FeistyFettuccine
Posts: 13
Joined: Thu Jul 11, 2019 1:26 pm

Re: Invisible mask - can't get it to work

Post by FeistyFettuccine » Mon Aug 12, 2019 2:00 pm

hayasidist wrote:
Thu Aug 08, 2019 8:10 pm
FeistyFettuccine wrote:
Thu Aug 08, 2019 12:56 pm
hayasidist wrote:
Thu Aug 08, 2019 10:25 am
… just ask if you want to see a file with those two options at work
Yes please. ...
here's the file http://www.mediafire.com/file/dv694oa6g ... .moho/file -- hope that helps (as should Dennis's)
Thank you, will dissect this. Thanks.
User avatar
SuperSGL
Posts: 113
Joined: Wed Mar 11, 2015 2:55 am
Location: New Hampshire

Re: Invisible mask - can't get it to work

Post by SuperSGL » Wed Aug 14, 2019 9:16 pm

Came here looking for mask questions and found this. Extremely helpful. I to get so confused that I end up making a huge mask over the entire screen (slight exaggeration) Just to hide or reveal. Thanks Greenlaw & hayasidist for the files. Again very helpful.
BTW I tried it on my file and on the files I downloaded but If you add motion blur to (for example) the star It is no longer masked? Any work arounds for that?
"Animation is not the art of drawings that move but the art of movements that are drawn."
Norman McLaren
User avatar
Greenlaw
Posts: 4467
Joined: Mon Jun 19, 2006 5:45 pm
Location: Los Angeles
Contact:

Re: Invisible mask - can't get it to work

Post by Greenlaw » Wed Aug 14, 2019 10:55 pm

That's interesting...I'll have to take a look at that when I get home this evening.

I don't normally render motion blur in Moho because it can really slow down rendering. When I do need a mo-blur effect, I prefer to apply it as an effect in compositing.

In After Effects, for example, I would apply a native effects plugin called Pixel Motion Blur, which works really well most of the time. Alternatively, I use a commercial plugin called ReelSmart Motion Blur, which is a bit faster than PMB and has a lot more options. I sometimes switch between the two, or even use both in the same scene because they can produce slightly different results.

Black Magic Design's Fusion is another compositing program I use, and it has its own optical flow tool for this effect. IMO, Fusion is the bargain of the century since they dropped the price to $299. I remember paying $2,000 for Fusion years ago and that price had been discounted from $4,000! Anyway, if you're serious about compositing, I highly recommend this program.

I wish Moho could output a motion vector channel for and embed that data in a EXR file. This would allow the motion blur effect to look more accurate with these compositing options. (This is what I do for 3D animation renders and it's a HUGE timesaver. It also opens a lot more creative opportunities for the animation in compositing.)
D.R. Greenlaw
Artist/Partner - Little Green Dog | Little Green Dog Channel on Vimeo | Greenlaw's Demo Reel 2019 Edtion
Lead Digital Animator, Dreamworks Animation

Image
User avatar
SuperSGL
Posts: 113
Joined: Wed Mar 11, 2015 2:55 am
Location: New Hampshire

Re: Invisible mask - can't get it to work

Post by SuperSGL » Wed Aug 14, 2019 11:35 pm

Just a Home Hobbyist, I use Corel Video Studio. It would work ok for compositing but only on separate files and a lot of work (although the latest version have masks you can apply by drawing on the animation I haven't done anything with that yet).

I had this Sci Fi /Jetsons type cartoon where a console pops up through a hole in the floor very quickly, thought it could use a little something, but now I'm thinking more of a slight elastic bounce motion
might actually look funnier that way.

It just surprised me that it seems to disabled the mask. I use soft edges for shadows and hi lights and those get masked just fine (I know that's a different animal but...)

Besides this cartoon is for the AnimeStudio Tutor competition ' Robots ' They want most of your effects done in the program anyway. I'll do everything but the music and sound (I can't stand using Moho for this part) Anyway it also seems to be the only way I can actually finish an animation :cry:

Thanks for your response (even though I snucked it in somebody else's post :lol: )
"Animation is not the art of drawings that move but the art of movements that are drawn."
Norman McLaren
hayasidist
Posts: 2145
Joined: Wed Feb 16, 2011 8:12 pm
Location: Kent, England

Re: Invisible mask - can't get it to work

Post by hayasidist » Thu Aug 15, 2019 9:14 am

yes -- the "ghost" images from motion blur aren't masked (12.5 and 13.0). IMO a bug -- it's logged - 39960.
Post Reply