Here's some handy scripts

Moho allows users to write new tools and plugins. Discuss scripting ideas and problems here.

Moderators: Fahim, Distinct Sun, Víctor Paredes, erey, Belgarath, slowtiger

Genete
Posts: 3483
Joined: Tue Oct 17, 2006 3:27 pm
Location: España / Spain

Post by Genete » Tue Aug 14, 2007 8:03 pm

Thanks bupaje!!!
It works pretty well!
-G
User avatar
bupaje
Posts: 1175
Joined: Fri Nov 12, 2004 5:44 pm
Location: California
Contact:

Post by bupaje » Tue Aug 14, 2007 8:05 pm

That's great. If someone saves the images that would be great. Sometimes they lose stuff as it gets older.
[url=http://burtabreu.animationblogspot.com:2gityfdw]My AnimationBlogSpot[/url:2gityfdw]
User avatar
mooncaine
Posts: 206
Joined: Wed May 04, 2005 9:31 pm
Location: atlanta, ga, usa

Post by mooncaine » Tue Aug 14, 2007 8:17 pm

Bupaje, I see that you are a hero among us, like Genete and Heyvern. Thank you so much.

For now, I have captured all those pages to PDF. Later, I will combine them, but I probably won't take time to edit the content. If anyone would like this combined, huge PDF, send me a PM. If enough requests come, I'll just put it online for people to download.... but I can't even think about it til the weekend. For now, just know that I am grateful for the Wayback Machine idea, and that I've attempted to save that info by printing it to PDF on my Mac.
-=-
MacBook Pro 17", 2.16Ghz, 2GB RAM, 5400rpm 120GB HD
ASP 5.5 updated August 2007
OSX 10.4.9
User avatar
bupaje
Posts: 1175
Joined: Fri Nov 12, 2004 5:44 pm
Location: California
Contact:

Post by bupaje » Tue Aug 14, 2007 8:30 pm

Ha! I wish. I just think this is a very cool forum, and love the product. Even though I haven't actually played with AS in about 18 months I can't keep away and now that I'm in an animtion company I've bugged several pros to try it out. :) In fact I am working now but have the forum open - I'm addicted. ;)
[url=http://burtabreu.animationblogspot.com:2gityfdw]My AnimationBlogSpot[/url:2gityfdw]
len
Posts: 22
Joined: Thu Jun 22, 2006 10:26 pm
Contact:

Post by len » Mon Jan 21, 2008 3:14 pm

Hi all.
I'm still desperate to get the Crash Core scripts working again.
I didn't quite understand the previous discussion on restoring images that would explain how to get around the SaveBool error that comes up on a bunch of the scripts?
(In particular I need to shift keyframes around)
I looked back to the image links from Page 1 of this thread but they're just for "blueLine.jpg" or some such. Didn't help much.

Any help is greatly appreciated.
evseeva
Posts: 1
Joined: Wed Jul 08, 2009 7:45 pm
Location: Moscow, Russia
Contact:

Post by evseeva » Thu Jul 09, 2009 8:24 pm

len wrote: how to get around the SaveBool error that comes up on a bunch of the scripts?
Any help is greatly appreciated.
Here is a zip archive with two corrected scripts: save_layer_animation and load_layer_animation. Now without SaveBool error and so on.

BTW, did anybody see a script witch sets keys for multiple layers, just like these scripts save and load them?
Breinmeester
Posts: 294
Joined: Thu May 13, 2010 2:01 pm

Post by Breinmeester » Mon Sep 20, 2010 2:52 pm

Rhoel,

Could I place a script request here?

I could really use a script that puts a keyframe on all (or selected) channels for either the selected layer, the selected layer and any child layers or the whole document. That would include keyframes for the positions and rotations of points and bones.
It would be a handy extra if you could select the interpolation mode for the keyframes.

The reason I post this here is because your 'splat layer keyframe interpolation' script already does something that comes close. Maybe you could alter it?

Also, it would be a welcome addition if one could select 'the current frame' as the source range in your 'splat layer keyframe interpolation' script.

Thanks for some very handy scripts!
User avatar
Datawraith
Posts: 73
Joined: Fri Jun 11, 2010 2:50 am

Post by Datawraith » Wed Oct 13, 2010 1:23 am

aww. I'm very late to the party. Can someone reupload the reverse keyframes script?
A device that makes bad weather. . . interesting :/
User avatar
capricorn33
Posts: 249
Joined: Sun Oct 02, 2005 9:49 am
Location: Finland
Contact:

Re:

Post by capricorn33 » Mon Aug 27, 2012 4:12 pm

evseeva wrote:
len wrote: how to get around the SaveBool error that comes up on a bunch of the scripts?
Any help is greatly appreciated.
Here is a zip archive with two corrected scripts: save_layer_animation and load_layer_animation. Now without SaveBool error and so on.

aargh. This link is dead...

Does anyone have these corrected versions of the Crashcore v 1.4 load/save layer animation-scripts...?
The ones WITHOUT the SaveBool error...? And working on ASP 8.2 ?

I would be most happy if anyone could share. I don't have the time myself to start digging in the code right now.

cap
capricorn ( - just call me "cap")
children's tv pro, character animator
ulrik
Posts: 1075
Joined: Thu Aug 11, 2005 10:32 pm
Location: Stockholm Sweden
Contact:

Re: Re:

Post by ulrik » Mon Aug 27, 2012 6:18 pm

capricorn33 wrote:
evseeva wrote:
len wrote: how to get around the SaveBool error that comes up on a bunch of the scripts?
Any help is greatly appreciated.
Here is a zip archive with two corrected scripts: save_layer_animation and load_layer_animation. Now without SaveBool error and so on.

aargh. This link is dead...

Does anyone have these corrected versions of the Crashcore v 1.4 load/save layer animation-scripts...?
The ones WITHOUT the SaveBool error...? And working on ASP 8.2 ?

I would be most happy if anyone could share. I don't have the time myself to start digging in the code right now.

cap
Here you have:
https://www.dropbox.com/s/rmd32xnhn26ctqx/Arkiv.zip
I don't know if it's the latest but it is working in v.8.2, however it's only working if you save it "only apply to selected layer" and open it with "start with selected layer"
It would be great if someone could fix it.
User avatar
capricorn33
Posts: 249
Joined: Sun Oct 02, 2005 9:49 am
Location: Finland
Contact:

Re: Here's some handy scripts

Post by capricorn33 » Mon Aug 27, 2012 7:05 pm

Thanks Ulrik!

I got it working for the purpose I needed right now (copying a lot of point animation between projects...)

When I find the time for it I will have a look at the script and see if I maybe can fix it. But that won't happen in a few months now... too busy... .-)

Thanks again for the upload, Ulrik!
capricorn ( - just call me "cap")
children's tv pro, character animator
Breinmeester
Posts: 294
Joined: Thu May 13, 2010 2:01 pm

Re: Here's some handy scripts

Post by Breinmeester » Thu Aug 30, 2012 10:59 am

I really like the Crashcore scripts. But I just tried the Relink Lost Images script on v8 and it did find all the images but the placement of them on screen was off. Does somebody know what changed in v8 so we can fix it?
User avatar
oliver43
Posts: 33
Joined: Fri Sep 15, 2006 6:41 pm

Re: Here's some handy scripts

Post by oliver43 » Wed Nov 28, 2012 7:54 pm

Im looking for a copy of the 're-link lost images' script.. and any other other scripts up for grabs... LInks? everyone I try seems to be dead.

Thanks,
o
User avatar
cableon
Posts: 151
Joined: Thu Jan 17, 2008 6:44 pm
Contact:

Re: Here's some handy scripts

Post by cableon » Thu Apr 18, 2013 1:42 pm

Hi everyone,
I have just upgraded to ASP 9.2 and it ROCKS!! Awesome, fast & handy new features...

Re-installed the cc_reverse_layer_keyframes too, putting it into the menu file, but it doesn't seem to work here though -- here is the message I got when attemting to reverse a selection of keyframes on a single layer :

Code: Select all

../ts/menu/Layer effects/cc_reverse_layer_keyframes.lua:528: attempt to index local 'layer'(a nil value)
Any idea how to get this right anyone please ?
User avatar
cableon
Posts: 151
Joined: Thu Jan 17, 2008 6:44 pm
Contact:

Re: Here's some handy scripts

Post by cableon » Fri Apr 19, 2013 1:07 am

Oops, got it, no need for scripts, should have had a closer look at ASP 9's new features video... :)
Post Reply