Vector drawing disappears when selecting bone layer

(This forum has been closed. Please use the General Moho Discussion forum.)

Moderators: Fahim, Distinct Sun, Víctor Paredes, erey, Belgarath, slowtiger

Locked
User avatar
SteveRyan
Posts: 12
Joined: Thu Aug 05, 2004 6:41 am
Location: Seattle area, Washington, USA
Contact:

Vector drawing disappears when selecting bone layer

Post by SteveRyan » Fri Feb 25, 2005 6:08 am

Ever since version 5 came out I have an issue where I
Create a drawing on a vector layer
Create a new bone layer and drag the vector layer into it
Select the bone layer to add bones; but the image on the vector layer disappears. That is, the layer is still there but the image is not visible so long as I have the bone layer selected.

I've been through the tutorial three times and it works fine with tutorial. But when I start a new file, I get the problem.
myles
Posts: 821
Joined: Sat Aug 21, 2004 3:32 am
Location: Australia, Victoria, Morwell
Contact:

Re: Vector drawing disappears when selecting bone layer

Post by myles » Fri Feb 25, 2005 7:36 am

SteveRyan wrote:Create a drawing on a vector layer
Create a new bone layer and drag the vector layer into it
Select the bone layer to add bones; but the image on the vector layer disappears. That is, the layer is still there but the image is not visible so long as I have the bone layer selected.
Hi Steve,

try clicking on the Display Quality button on the bottom right of the main workspace and either select Wireframe display mode or uncheck both Fills and Outlines - and make sure the Construction Curves option is checked.

Having either Fills or Outlines checked seems to cancel out the display of the construction curves.

I'm not sure if this counts as a bug or Just The Way It Works - any comments, Lost Marble?

Regards, Myles.
User avatar
Lost Marble
Site Admin
Posts: 2193
Joined: Tue Aug 03, 2004 6:02 pm
Location: Scotts Valley, California, USA
Contact:

Post by Lost Marble » Fri Feb 25, 2005 5:37 pm

In Moho 5, the construction curves are only displayed for the current layer. Construction curves being the points and curves you create with the Add Point tool, etc. If you create some fills and outlines, those will still show up when you switch to a different layer, just not the underlying construction curves.

In this case, it sounds like you've drawn out the basic shapes, but you haven't used the Create Shape tool to fill them with any colors. You have two options:

1. Add some fills and outlines to your vector layer. Then, when the bone layer is active, the fills and outlines will still be visible.

2. Select the vector layer. Click the "Current Layer" tab at the bottom of the main Moho window. In the popup that appears, turn on the checkbox marked "Construction curves". This tells Moho to show those construction curves even when the layer is not selected. You can now go back to the bone layer and the construction curves for the vector layer will still be visible.
myles
Posts: 821
Joined: Sat Aug 21, 2004 3:32 am
Location: Australia, Victoria, Morwell
Contact:

Post by myles » Sat Feb 26, 2005 4:56 am

Lost Marble wrote:2. Select the vector layer. Click the "Current Layer" tab at the bottom of the main Moho window. In the popup that appears, turn on the checkbox marked "Construction curves". This tells Moho to show those construction curves even when the layer is not selected.
Ahh! I have a better understanding now, I think. I hadn't really looked at "Current Layer" - thanks for the clear explanation!

Regards, Myles.
"Quote me as saying I was mis-quoted."
-- Groucho Marx
User avatar
SteveRyan
Posts: 12
Joined: Thu Aug 05, 2004 6:41 am
Location: Seattle area, Washington, USA
Contact:

Post by SteveRyan » Sat Feb 26, 2005 10:23 pm

Dooh!!

I knew it was something stupid on my part. I hadn't added a fill or an outline.

Or I guess I could also did the "current layer" thing.

thank you for your help!
Locked